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TIBCO Spotfire Documentation and Support Services

How to Access TIBCO Documentation

Documentation for TIBCO products is available on the TIBCO Product Documentation website, mainly
in HTML and PDF formats.

The TIBCO Product Documentation website is updated frequently and is more current than any other
documentation included with the product. To access the latest documentation, visit https://
docs.tibco.com.

Product-Specific Documentation

The following documents for this product can be found in the TIBCO Documentation Library:
e TIBCO Spotfire® Analyst — User’s Guide

o TIBCO Spotfire® Analyst — License Agreement

e TIBCO Spotfire® Analyst — Release Notes

o Working with Cubes in TIBCO Spotfire®

Related Documentation

The following document related to this product can be found in the TIBCO Documentation Library:
o TIBCO Spotfire® Server and Environment — Installation and Administration manual

Release Version Support

Some release versions of TIBCO Spotfire products are designated as Long Term Supported (LTS)
versions. LTS versions are typically supported for up to 36 months from release. Defect corrections will
typically be delivered in a new release version and as hotfixes or service packs to one or more LTS
versions. See also https://docs.tibco.com/products/tibco-spotfire-general.

How to Contact TIBCO Support

You can contact TIBCO Support in the following ways:

e For an overview of TIBCO Support, visit http://www.tibco.com/services/support.

o For accessing the Support Knowledge Base and getting personalized content about products you are
interested in, visit the TIBCO Support portal at https://support.tibco.com.

o For creating a Support case, you must have a valid maintenance or support contract with TIBCO.
You also need a user name and password to log in to https://support.tibco.com. If you do not have a
user name, you can request one by clicking Register on the website.

System Requirements for Spotfire Products

For information about the system requirements for Spotfire products, visit http://support.spotfire.com/
sr.asp.

How to Join TIBCO Community

TIBCO Community is the official channel for TIBCO customers, partners, and employee subject matter
experts to share and access their collective experience. TIBCO Community offers access to Q&A forums,
product wikis, and best practices. It also offers access to extensions, adapters, solution accelerators, and
tools that extend and enable customers to gain full value from TIBCO products. In addition, users can
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submit and vote on feature requests from within the TIBCO Ideas Portal. For a free registration, go to
https://community.tibco.com.

For quick access to TIBCO Spotfire content, see https://community.tibco.com/products/spotfire.
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Introduction

This guide contains information that can be useful if you are working with cube data in TIBCO
Spotfire®.

What is a Cube?

An OLAP (Online Analytical Processing) cube is a multi-dimensional representation of data.
The OLAP cube consists of a set of measures (or facts) and a number of dimensions.

Dimensions organize the data for a user in relation to an area of interest, such as customers, stores, or
geographies. Dimensions are usually hierarchical in nature. Measures (facts) reside in the intersections
between the dimensions. As such, the measures or facts are aggregated by the cube itself (either
beforehand, or, they are dynamically calculated).

This differs from relational databases where the measures or facts are stored in the database table and
you apply aggregation methods when the database table is queried.

Cube Example

In the schematic image above, the sides of the cube could be said to represent
different dimensions and the cell contains the associated measure.

As a simplification, if side 1 represents product type, side 2 is a time unit, and side 3
is region, then the cube could be queried in several different ways: the yellow plane
could mean "Show sales per product for different years.", the pink plane could mean
"Show sales per product in different regions." and the blue plane "Show sales per
region for different years.".

In Spotfire, an OLAP cube is represented as a table. If you are new to Spotfire, a good starting
visualization to use is the cross table visualization (also known as a spreadsheet).

What are Measures?

Measures is a general name for measurements, metrics or facts which are of interest in the data
analysis. Measures are mostly numerical in nature. Examples of measures are sales, quantity, accounts,
and so on.

A measure value is computed for a given point or cell by aggregating the data corresponding to the
respective dimension intersection for the cell.

Working with Cubes in TIBCO Spotfire®



In Spotfire, each measure is represented as a column. Such a column is generally what you would put
on the value axis of a visualization. Since measures are calculated by the OLAP cube you cannot change
the aggregation method for measures in Spotfire.

In SAP BW, measures are referred to as 'Key Figures'.

What is a Dimension?

Dimensions organize the data in relation to an area of interest. Dimensions can be things like
customers, stores, or geographies, and they are usually hierarchical in nature.

Different OLAP cube systems see dimensions differently. Some systems see dimensions as a container
for related area of interests (for example, where the Customer dimension contains Occupation and
Gender hierarchies), whereas other systems see dimensions as hierarchies. For systems that see
dimensions as hierarchical, each dimension implicitly becomes a hierarchy.

In Spotfire, dimensions cannot be put in a visualization. They are a way to organize related data and
can be seen in the Data panel and in the Views in Connection dialog, as a means of finding relevant
data. Instead, it is the hierarchies that are used on axes in Spotfire visualizations.

SAP BW distinguishes between 'Key Figures' and 'Characteristics'. Key figures become measures in
Spotfire, and all characteristics will be found in the 'Characteristics' dimension.

In Oracle Essbase, all dimensions are hierarchical in nature. In Spotfire, the Essbase dimensions are all
shown as hierarchies.

What is a Hierarchy?

A hierarchy defines a set of parent-child relationships. Typically, a parent member belongs to a more
general concept than its children and the parent member "summarizes" its children. Parent members
can further be aggregated as the children of other parents.

A hierarchy can also be viewed as a set of mappings from a set of low-level concepts to higher-level,
more general, concepts. Each concept is given a name — its level name. The levels are ordered so that a
"more general" level precedes a "less general" level.

Each concept or level consists of a set of values. The level values are called members. Each member has
a name and a key where the key is guaranteed to be unique.

As an example, consider a 'Geography' hierarchy that has the concepts of 'Country' and 'City', where
'Country' is more general than City'. That is, the 'Geography' hierarchy has two levels 'Country' and
'City', where the 'Country' level precedes the 'City' level. There are two members; 'US' and 'Germany’,
who belong to the 'Country’ level and four members Boston' (whose parent is 'US'), 'Hamburg' (whose
parent is 'Germany'), '‘Berlin' (whose parent is Germany), and 'Berlin' (whose parent is US), who belong
to the 'City' level.

Geographical hierarchy example.

EEE Geography (hierarchy) Al

Country

City [ Bosten | | Berin | [Hamburg] [ Berin |
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Hierarchies are commonly referred to as categories in Spotfire. That is, hierarchies are generally what
you would put on the categorical axis of a visualization. A hierarchy with only one (1) level is
represented as a column in Spotfire. A hierarchy with more than one level is represented as a hierarchy
in Spotfire.

Cube Queries

When working with in-database cube data, Spotfire creates MDX (MultiDimensional eXpression)
queries that are sent to the cube query engine to get results back.

In an MDX query, all hierarchies in the cube matter, even if they are not specified in the query. If a
hierarchy is not specified in a query, then the default member of that hierarchy is used. You can view
this as an implicit slicing of the cube on the default member. The default member is usually a member
that denotes "all possible items", but this is not always the case.

For example, if you have a cube that contains one measure ('Sales') and two hierarchies ('Time' and
'‘Countries') and you use Sales on one axis and Time on another axis in a visualization. The result you
will get back is Sales over Time for all countries. If you are using a currency dimension or hierarchy; it is
not uncommon that the default member is a specific currency and not "all currencies". That means that
you will get the value (e.g., Sales) for the currency that is the default currency. If this is not what you
want, then you should ask your cube administrator to change the default member in the cube (only
possible in Microsoft SQL Server Analysis Services), or, provide a Spotfire filter for the currency
hierarchy, where you can select which currency to display.

If you do not see any data in your visualizations, it could be that no data has been aggregated for the
combination of default member or members and the specified hierarchies in the cube. A potential
remedy to this situation is to explicitly slice or dice the cube by applying the appropriate Spotfire filter
for the hierarchy or hierarchies where default members are used.

Theoretically, you could split a query enough to return the actual values from the underlying data
warehouse, but the cube would still consider the query as aggregated.

Large OLAP Hierarchies in Spotfire

When you are analyzing external cube data in Spotfire, you may encounter situations when a hierarchy
filter takes a really long time to load, or even fails to load. This happens because the filter is populated
in advance by reading the hierarchy outline from the cube. If the hierarchy is large (with many different
levels and categories), the loading of all values at once may even cause problems for the cube data
source itself.

If you notice that the creation of a filter takes an unreasonably long time, or, if you know that your cube
contains a very large hierarchy, you can configure the hierarchy to be loaded on request in the filter,
instead of loading the entire hierarchy at once.

Configuring a Cube Hierarchy to be Loaded on Request

These steps describe how a cube hierarchy can be configured to be loaded on request, so that large
OLAP hierarchies can be handled in Spotfire.

& ‘ This configuration must be done separately for each large hierarchy in the cube data connection.

In this example, an embedded data connection to a Microsoft SQL Server Analysis Services cube is used
as an example, but you can use the same steps to configure hierarchies from any cube data source.

Procedure

1. Select File > Add Data Tables.
2. Click Add > Connection To > Microsoft SQL Server Analysis Services.

3. Specify the Server you want to connect to.
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Click Connect.
Select the Cube of interest.
Click OK.

In the Data Selection in Connection dialog, click on the object of interest in the left pane, then click
Add >.

8. In the Data selection in connection list, locate the large hierarchy that you want to load on request
and right-click on it.

N o 9o

9. From the pop-up menu, select Load Values on Request.
10. Repeat steps 8 and 9 for all hierarchies that you want to load on request.

11. When you are done with the data connection configuration, click OK.
The connection is added to the Data tables list in the Add Data Tables dialog.

12. Make sure Keep data external is selected under Load method.
13. Click OK in the Add Data Tables dialog.

Result

When creating a filter for the hierarchy, the values in the filter will be loaded on request.

You can edit a previously created embedded data connection by selecting Edit > Data Connection
¥ Properties, clicking Settings and then clicking Edit. A data connection saved in the library is edited by
’ selecting Tools > Manage Data Connections, browsing to the connection in the library and clicking
Edit.

Hierarchy Filters Loaded on Request

When the connection has been configured to load values on request, the hierarchy filter will query the
cube for the currently shown values only, and a new query is sent to the cube each time a new category
is expanded.

When hierarchies are loaded on request, the filter cannot display the search field that is otherwise
available. You may also see progress indications for each category you expand, as new values are
fetched from the external source.

Hierarchy
W Al
-l |M| Eurocpe
# |+| France
-l (W] Germany
| = Berin
+ 1] Frankfurt

Hierarchy filters from external cube sources will include an (All) check box and the setting that
indicates that a category is only partially selected will be turned on by default. These settings can be
switched off in the Filtering Scheme Properties dialog.

Working with Cubes in TIBCO Spotfire®
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Common Operations on Cubes and their Spotfire Equivalent

Some common operations on cubes have a corresponding action in the Spotfire environment.

Operation

Explanation

Corresponding Spotfire
Equivalent

Slicing

Slicing is the act of picking a subset
of a cube by choosing a single value
for one of its dimensions.

In Spotfire, slicing is done by
bringing up a filter for the
hierarchy and selecting one value.

The fastest way of doing this for a
multi-level hierarchy is to bring
up the hierarchy filter, select the
single value, right-click and
choose Deselect Other Values.

Dicing

Dicing is the act of picking specific
values from dimensions.

Dicing is done by bringing up
filters for the hierarchies in
question and selecting the specific
values in those hierarchies.

Drill-down and Drill-

Drill-down and drill-up are used to

This is done by selecting the

up navigate among levels of data hierarchy that the levels belong to
ranging from the most summarized on a categorical axis and moving
(up) to the most detailed (down). the hierarchy slider to the left
(drill-up) or to the right (drill-
down).
Rotating/Pivoting Rotating (or Pivoting) is the act of In Spotfire, rotating is done by

changing the dimensional
orientation of a report or page
display. For example, a rotating
operation may consist of swapping
the rows and columns, or by moving
one of the row dimensions to the
column dimension.

moving the hierarchies to a
different categorical axis.

Nesting (of multi-
dimensional columns
and rows)

Nesting is a display technique used
to show the results of multiple
hierarchies on a column or row.

The column or row labels will
display the extra dimensionality of
the output by nesting the labels
describing the members of each
hierarchy.

Nesting in Spotfire is done by
selecting the hierarchies "in
nesting order" on a given
categorical axis.

The leftmost hierarchy is the top
of the nesting and the rightmost
hierarchy is at the bottom of the
nesting.

Combining OLAP Data and Other Data in the Same Analysis

Hierarchy values in a cube have both a caption and key. The key will always be unique, but the caption
can be the same as for another hierarchy value. The key can be used for identifying a value. When you
visualize data from an in-database cube in Spotfire, you may encounter cases where you cannot
separate multiple instances of a value from each other (for example, when there are more than one city
in the world with the same name (i.e., caption), like the case with Paris, France and Paris, Texas) in a
visualization. In that case, you probably want to match values based on the keys, rather than on the

Working with Cubes in TIBCO Spotfire®
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values themselves. This is done by selecting the KeyOf method on the matching column of the cube
directly.

When you want to combine cube data and other data (for example, data from a relational database) you
must have a column that matches the cube's KeyOf values in the relational data. The keys can often be
exported from the cube to provide good matching.

If a KeyOf-value is missing in a cube, an error message will be displayed in the visualization that shows
the cube data. In the details for the error it will be indicated that an error occurred in the external data
source. For example, this could occur if you configure a relation between a cube and a data table
coming from another external system, and the data in the other system contains the key Hannover
whereas the cube key is called Hanover. When Hannover is used in cube database queries, no key is
found and an error is shown.

Defining a New Relation Between a Relational Data Table and a Cube Data Source Using

Keys

If you have data in a cube data source and want to be able to use this data to retrieve details about a
certain value from a relational data source on demand, or if you simply want to be able to propagate
markings from the cube data source to visualizations based on the relational source, you may want to
define a relation between the two data tables.

Prerequisites

You must have a data table based on a cube data source and one data table from a relational source
available in the analysis.

Procedure

Select Edit > Data Table Properties.

Go to the Relations tab.

Click on Manage Relations.

In the Manage Relations dialog, select the data table to Show relations for.
Click New.

S T e

Select the cube data table you want to connect to from the Left data table drop-down list and the
relational data table from the Right data table drop-down list.

~

Select the column containing the identifiers in the Left column and Right column drop-down lists.

8. Provided that the cube data source is on the left, under Left method, select the KeyOf method.

Comment: This specifies that the match should be done using the cube key of that identifier and not
the actual value.

9. Click OK to close all dialogs.
Result
The relational data table and the cube data table are now related.

When you are using a cube hierarchy on an axis in a visualization you will automatically see the
caption and not the key. To explicitly show the keys in your visualizations, you need to set up a custom
expression.

Working with Cubes in TIBCO Spotfire®



14

Creating Column Matches Based on Keys to View Cube Data in the Same Visualization
as Other Data
If you have two columns with the same dimension values in a cube data source as well as in a relational

data source and you want to display the data in the same visualization you may need to apply the
KeyOf method to match the values.

Prerequisites

You must have a data table based on a cube data source and one data table from a relational source
available in the analysis.

Procedure

SN T e

Select Edit > Data Table Properties.

Go to the Column Matches tab.

In the Data tables list, select the cube data source.

Click New.

In the New Match dialog, select the other data table of interest under Right data table.

Make sure the columns with the matching information are selected in the Left matching column
and Right matching column selectors.

7. Open the column selector for the cube column under Left Matching column and select Methods to
open the menu.

8. Select KeyOf.
Comment: It is not possible to use KeyOf as a transformation, it must be applied directly as a
method on the matching column.

9. Click OK to close all dialogs.

Result

You can now show data from both the cube data and the relational data in the same visualization.

When you are using a cube hierarchy on an axis in a visualization you will automatically see the
& caption and not the key. To explicitly show the keys in your visualizations, you might need to set up a
custom expression.

Working with Cubes in TIBCO Spotfire®
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Limiting Data

When specifying what data to work with in the Data Selection in Connection dialog, you also have the
possibility to limit further on dimensions. Single sublevels in hierarchies can be selected or deselected.
Limiting the dimension to view only the required data is of particular interest when you intend to
import your cube data, since too large amounts of data cannot be imported from the cube. Some data
sources may also have limits on the number of cells which you may import.

If you are using SAP BW BEx queries, data has already been limited due to the selections in the BEx
& query, so further limiting is often unnecessary. Make sure that you do not filter out all data by selecting
values that have already become invalid by the selection of BEx variables.

Procedure

1. Select to add a data connection from a cube data source, such as Microsoft SQL Server Analysis
Services, and provide all the necessary input for the connection to the data source.

For more information about specific system settings, see the section about the system of interest in
this user's guide.

2. In the Data Selection in Connection dialog, click on the column or hierarchy to limit in the Data
selection in connection list.

3. In the Settings pane, click Limit....

4. In the Limit Data dialog, clear the check boxes for those categories that you do not want to include
in your selection.

You can also right-click in the dialog to display a pop-up menu where you can Select All Values or
Deselect Other Values (clears the check boxes for all values except for the value you right-clicked
on).

5. Click OK.

Working with Cubes in TIBCO Spotfire®
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Data Selection in Connection

When you define a new data connection you get the option to select which cube data should be
included in the connection. If the data is going to be imported, it is important to limit the data as much
as possible, because too large selections cannot be imported.

Data Selection in Connection X

The cube structure is shown below. Make selections or Data selection in connection:

search to limit what is shown.

Type to search Seffings:
=ex Varables Typs o search &
sex Variables (1) Mandatory not intial
) Discount (Defaut) Value presentation:
(1) Categories (Prompted) Text "
C Add = ) (L) States (Defined) Variable value:
El> Key Figures o C;'j SALESDATA. . Define Value. .
5 Costs < Remove E|E Characteristics
% Discount ""E‘ Category
5 Sales BE‘ Region
Gl Chamcieristics — Region
5L Cagon oL Ste
; 17 Region

wel Sate Prompt for values
Prompt type:
Muttiple selection w
Min selections: Max selections:
1 = |15 =

Load values automatically

Description:

Select the categories you want to analyze.

Order of Prompts...

Estimate Impart Size

Cancel

Option Description

The cube structure is
shown below. Make
selections or search to
limit what is shown.

The left pane shows the structure of the cube you have selected in the
previous connection dialog.

If you have connected to Microsoft SQL Server Analysis Services, then
you will have the option to select a single measure group using a drop-
down list.

For all cubes it is possible to locate items containing specific words in the
cube or query by typing some text in the search field.

When you have located the data of interest, click to select it in the left
pane, then click Add >.

Note that you can only select full hierarchies and not parts of a hierarchy
when adding items to the Data Selection in Connection list.

See Icon Descriptions for more information about what the icons in the
list mean.

Double-clicking on an item will expand/collapse the item in the list if
possible, or, if it is a leaf node, add the item to the Data selection in
connection list.

Working with Cubes in TIBCO Spotfire®
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Option Description

Add > Adds the data selected in the left list to the Data selection in connection
list.

< Remove Removes the selected data from the Data selection in connection list.

Data selection in Lists the data that you have added from the cube.

connection

If you are using SAP BW and have selected a BEx query, then any BEx
variables will automatically be added to this list. You must define a value
for all variables that are listed as required.

Type some text in the search field to locate specific words in the field.

Columns or hierarchies that have been used to limit the data may be
indicated by the addition of the text (Limited), depending on the settings

in the limitations menu, :=-. If specified, dimensions (columns or
hierarchies) that can be used to limit the data in the selection may be
shown in blue text.

Click on an item in the list to show settings for that item in the Settings
pane (if applicable).

See Icon Descriptions for more information about what the icons in the
list mean.

Double-clicking on an item will expand/collapse the item in the list if
possible, or, if it is a leaf node, remove the item from the right Data
selection in connection list.

You can specify that the data in the connection should be available as
external data only, or as imported data only, using the pop-up menu.
Right-click on the cube in this list and select Load Method > External
Data Only (In-database)or Load Method > Imported Data Only (In-
memory).

Data selection in connection:

iz Settings:
Type to search

sEx Varables
b (1) StatesVariable (Defined)

s SALFSDATA/RFP 20141112124247

g3 Load Method  » Allow All Methods
: Expand All | External Data Only (In-database) |
Collapse All Imported Data Only (In-memory)

You can also specify that a large hierarchy should load values on request
only by right-clicking on the hierarchy. See Large OLAP Hierarchies in
Spotfire for more information.

Displays the limitations menu where you can handle indications related
to data limiting in the Data selection in connection field.

11
4

Indications may help you see which columns can be limited and/or which
columns have been limited, but they can also be removed completely to
get a cleaner user interface.

Working with Cubes in TIBCO Spotfire®
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Option Description

No Indications Removes all indications.

Indicate All Columns Shows all columns or hierarchies that are possible to limit in a blue color.
Possible to Limit

Indicate All Limited Appends the word (Limited) to all columns or hierarchies that have been

Columns limited.

Clear All Limitations Removes all previously specified limitations from the selected data.

Settings Displays settings for the selected item in the Data selection in connection
list.

Value presentation

If you have selected a dimension, you will have the option to change the
Value presentation. You can choose to display text only, the technical key
or a combination of both.

Limit data

You also have the option to limit data for the selected dimension. It is
always recommended to limit the data as much as possible if you intend
to import data from the connection into Spotfire.

Clicking Limit... opens the Limit Data dialog where you can further limit
the data for the currently selected column. Note that it is only possible to
limit dimensions, because measures are calculated based on the selected
dimensions.

Click Clear to remove a previously added limit.
Define SAP BW BEx variables

If you are using SAP BW and have selected a BEx variable, you will have
the option to define the variable value. To define a static value for the
variable in the connection, click Define Value.

If a variable is 'Mandatory' or 'Mandatory not initial', you must define a
value or configure prompting for that variable if no default value has
been defined already.

Prompt for SAP BW BEx variables

For BEx variables, you can define prompting to let the end user define the
variable value. Prompting can be used in place of defining the BEx
variable in the connection, for greater flexibility.

To create a prompt for the selected BEx variable, select the check box
Prompt for values. For more information on prompting for BEx variables,
see Details on Prompting for SAP BW BEx Queries.

Working with Cubes in TIBCO Spotfire®
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Option Description

Estimate Import Size Opens a dialog where you can get an estimate of the size of the current
selection.

The size of the selected data is important when you are going to import
the data into Spotfire for in-memory analysis. See Data Import for more
information.

The values you get when doing an estimate depends on the system you
use and on the data in the cube. You can use the information to learn
whether or not this type of selection is possible to import from your
system. If you try an import and it fails, make sure the estimated import
size is lower the next time you try to import data. If the estimation takes a
long time it often, but not always, means that the selection is too big to
import.

Icon Descriptions

Different types of data are shown with a different icon in order to help you to quickly understand what
you see.

The icons are used in many different places in Spotfire. For example, when you create a new
connection, the icons are visible in the Data Selection in Connection dialog where you can specify
which data to include in the connection. The icons are also visible in the data panel when the
connection has been created and the data made available in Spotfire.

Icon Description

) Cube
@

Measure

Dimension

0 Sets

o Hierarchy

—
ooo

Hierarchy level 1

Hierarchy level 2

Hierarchy level 3

Hierarchy level 4

Hierarchy level 5

Hierarchy level 5+, used for all levels above level 5
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Sap BW specific icons

Icon Description

BEx variables

A mandatory BEx variable that must be defined

Working with Cubes in TIBCO Spotfire®



21

In-database Cubes in Spotfire

Because cube data is already aggregated from the start, aggregations are not performed by Spotfire
when working with in-db cube data. All aggregations that need to be done (if any) are pushed down to
the cube query engine. Instead, Spotfire can be used as a way to display the related combinations of
measures and hierarchies configured by the cube administrator.

By taking advantage of the natural structure of the cube you can make sure that you are viewing
relevant data. The free-dimensionality of Spotfire does otherwise allow you to make combinations of
measures and dimensions from the cube that do not always make sense, or lead to "The expression is
not valid"- messages in the visualizations.

Each time you change what is shown on the axes in a visualization based on in-db cube data, or make a
selection in a hierarchy filter or a check box filter, a request is sent to the cube to provide the selected
data. This means that if you make many changes in Spotfire, many requests may be sent to the database
instead of just the request for the final selection.

Spotfire uses a delay of about one second in order to see if there are any additional selections made in a
filter before sending the request to the database. This means that you should try to make coherent
changes in filtering in a steady pace and not pause for too long while selecting various check boxes. If
you pause for more than about a second, the current filter selection will be sent to the cube which will
start to provide the requested data. Making additional changes to the filter will send an additional
request to the database, causing a higher workload on the database, as the first request might still be
running.

Working with Cubes in TIBCO Spotfire®
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Microsoft SQL Server Analysis Services

If you have access to data in a Microsoft SQL Server Analysis Services system, you can use the
Microsoft SQL Server Analysis Services Connector in Spotfire to connect to your OLAP cube.

When you configure a connection to a Microsoft SQL Server Analysis Services cube, you can choose
whether to analyze data in-database or to import it into your analysis. Note that you need to install a
driver on your computer to get access to the Microsoft SQL Server Analysis Services connector. See the
system requirements at http://support.spotfire.com/sr_spotfire_dataconnectors.asp to find the correct
driver.

Dimensions and Attributes

Dimensions organize data with relation to an area of interest, for example, time, product, customer,
region, etc. An attribute is a kind of categorization.

For each dimension, you can be interested in a number of different dimension attributes. For example,
the 'Product’ dimension may be investigated with regard to the attributes 'Product.Color' or
'Product.Model'. These attributes can also be organized into multi-level hierarchies.

Measure Groups
Measure groups are used to associate dimensions with measures.

A cube includes measures in measure groups, business logic, plus a collection of dimensions that give
context for evaluating the numerical data that a measure provides.

Both measures and measure groups are an essential component of a cube. A cube cannot exist without
at least one of each.

Spotfire allows you to select a single measure group in the Data Selection in Connection dialog, which
can help you limiting the data from the cube:

Data Selection in Connection Data Selection in Connection

The: cube structune is shown below. Make select The cubs structune is shown below. Make select
limit what is shown. limit what is shown

{All measure groups) Sales Figures

Note that if you select a dimension belonging to another measure group you will automatically also
include that measure group in the selection and the measure group will also be visible in the Data
panel. (However, you will not get the measures from that measure group, only selected measures.)

Most of the times, you will probably only be interested in analyzing data from a single measure group,
but there may be exceptions. It is important to know what you are doing if you are working with cube
data in Spotfire. For example, if data is selected from two different, unrelated measure groups you
might end up with empty visualizations.

Hierarchies

Hierarchies are used to organize measures that are contained in a cube. In Spotfire, attribute hierarchies
and single-level user hierarchies are represented as columns, whereas multi-level hierarchies are
represented as hierarchies.

In Microsoft SQL Server Analysis Services, attributes are, by default, organized into two-level
hierarchies consisting of a leaf level and an optional 'All' level. The All level contains a single member —
the All member — which represents the aggregated value of the attribute's members across the related
measures. Note that if the hierarchy is non-aggregatable, the All level is not created.

Working with Cubes in TIBCO Spotfire®
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Henceforth, this structure is called an attribute hierarchy, to distinguish it from a user hierarchy. A user
hierarchy is a user-defined hierarchy of attributes that is used in Microsoft SQL Server Analysis
Services to organize the members of a dimension into a hierarchical structure that provide navigation
(drill-down, drill-up) paths, by which users can browse the data. The positions of members within the
hierarchy are controlled by the order of the attributes in the hierarchy's definition. Each attribute in the
hierarchy definition constitutes a level in the hierarchy.

Attribute hierarchies are represented as a single column in Spotfire, containing the leaf level members
and an implicit All member (if defined). The All member is not visible as a column value in Spotfire.

User hierarchies are represented as hierarchies in Spotfire unless the user hierarchy is a single level (1
level) hierarchy. Then the hierarchy is represented as a column in Spotfire.

Named Sets

Named sets return a data set based on a defined logic. They are primarily used to create data sets that
are often requested from the cube.

There are two types of named sets — static named sets and dynamic named sets.

Spotfire currently only supports named sets that return a certain single level in a user hierarchy or an
& attribute hierarchy (i.e., a 1-level hierarchy). That is, Spotfire can only handle results that can be seen as
a single column.

Static named sets are evaluated once during creation — they are never re-evaluated. Dynamic named
sets, on the other hand, are evaluated each time a query references it and is evaluated in a current
context. For example, a dynamic set may show the Top 50 customers. This dynamic set could either be
displayed over different countries in the world, or within a single country, when using standard cube
reporting tools.

When you are working with dynamic named sets in Spotfire, the content of a dynamic named set
column depends on the current context, that is, it depends on the current limitations and filtering.
Therefore, the axis expression must be evaluated after the current filtering is applied, when dynamic
sets are used in visualizations.

This is different from how axes traditionally are evaluated in Spotfire, but the 'evaluate after'-setting is
applied automatically when you are placing a dynamic named set column on an axis. See Details on
Advanced Settings help section in TIBCO Spottfire User's Guide (available under Help > Help Topics)
for more information about axis evaluation settings.

If you limit the selected data to male customers only, and use a set showing Top 50 customers, you will
get the top 50 male customers. If limitations make the number of available male customers lower than
50, then this is the number you will end up with. All of these calculations are handled by the cube.

If you are going to import data from a Microsoft SQL Server Analysis Services cube, and named sets are
included in the selection, the sets will be used to limit the data retrieved on import and to calculate the
measures. For example, if the selection of data to import contains data from Germany and France, and a
N Top 50 customers set is used in the import, the Top 50 customers from Germany and France are
imported. Filtering out Germany from the imported data may result in less than 50 values, because the
set will now show only those customers that were imported from France. The same selection of data
when working in-database will add the set as a dimension and the filtering will let you see the Top 50
values from France.

Microsoft SQL Server Analysis Services Cubes in Spotfire

Normally, you would use measures on axes where actual values are to be displayed, such as, on the
value axis of a bar chart, or as cell values in a cross table. Dimension columns, that is, attribute
hierarchies and user hierarchies, can be used to split the viewed data into smaller subsets on categorical
axes.

Working with Cubes in TIBCO Spotfire®
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When looking at cube data in the data panel you have the possibility to select one measure group and
one related dimension at a time, which may help you selecting suitable options on the axes. The whole
cube is treated as a single data table in Spotfire when you analyze it in-database.

There are also other implications of working with cube data. Since the measures are defined by the
context of a dimension, it is not possible to create filters for measures.

When importing cube data, all cube aggregations are lost. Hierarchies are imported down to the leaf
level and measure values for that level are retrieved. See Data Import more information.

Adding In-db Data from Microsoft SQL Server Analysis Services

Follow the steps below to add a connection with in-database data to Microsoft SQL Server Analysis
Services.

Procedure

10.

11.

12.

13.
14.

15.

Select File > Add Data Tables.
The Add Data Tables dialog is opened.

Click Add > Connection To > Microsoft SQL Server Analysis Services.
The Microsoft SQL Server Analysis Services Connection dialog is opened.

Specify the Server you want to connect to.

Click Connect.
Spottfire connects to the specified server, and the databases that are available on that server are listed
in the Database drop-down list.

Select the Database of interest.
Select the Cube of interest.

Click OK.

The Data Selection in Connection dialog is opened.
Click to select data of interest in the panel to the left.
Click on the top level to select the entire cube.

Limit what is shown in the panel by selecting a single measure group, or by typing a search term in
the search field.

Double-click on a collapsed item to expand it, or double-click on a leaf node to send it to the Data
selection in connection list.

Click Add > to move the selected data to the Data selection in connection field.

Dimension columns and hierarchies can be further limited by clicking the selected column or
hierarchy in the Data selection in connection list and then, in the Settings pane, clicking Limit....

This way, you can filter out certain values of the dimension to only include values of interest. For
example, you can select data from a single country only. Note that it is not possible to limit
measures, only dimensions, because the cube calculates the measures in the context of the selected
dimensions.

If desired, you can specify that the data in this connection should be available as external data only.
Right-click on the cube name and select Load Method and the desired option.

When you are done with the data selection, click OK.
The connection with the selected cube is added to the Data tables list in the Add Data Tables dialog.

Specify a descriptive Name for the connection.

Make sure the data table, and not the connection, is selected in the Data tables list and, under Load
method, click Keep data external.

Click OK.

Working with Cubes in TIBCO Spotfire®
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A connection to Microsoft SQL Server Analysis Services has now been added to the analysis, and a
default visualization is opened in Spotfire.

Importing Data from Microsoft SQL Server Analysis Services

Follow the steps below to import data from a Microsoft SQL Server Analysis Services cube.

Procedure

10.

11.
12.
13.

14.

15.

16.

Select File > Add Data Tables.
The Add Data Tables dialog opens.

Click Add > Connection To > Microsoft SQL Server Analysis Services.
The Microsoft SQL Server Analysis Services Connection dialog opens.

Specify the Server you want to connect to.

Click Connect.
Spottfire connects to the specified server, and the cubes that are available on that server are listed in
the Cube drop-down list.

Select the Database of interest.
Select the Cube of interest.

Click OK.
The Data Selection in Connection dialog opens.

If you want to limit your import to data from a single measure group, select the measure group of
interest in the drop-down list.

You can also type any text in the search field to find objects containing that text only.

Click on the object of interest in the left pane, then click Add >.

See Icon Descriptions for information about what the different objects represent. If you select the
cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add
the entire hierarchy to the list, but you can use the Limit Data button to filter out higher levels of
detail in the hierarchy from the actual selection at a later stage. You can repeat this step as many
times as you want to add more data to the selection.

The selected data is added to the Data selection in connection list.
Dimension columns and hierarchies can be further limited by clicking on the selected column or

hierarchy in the Data selection in connection list and then, in the Settings pane, clicking Limit....
The Limit Data dialog opens.

Clear the check boxes for categories that you want to remove from the selection.

Click OK to close the Limit Data dialog.

When you are done with your data selection it is recommended to click the Estimate Import Size
button to get a hint on whether this selection will be possible to import or not.

The calculation may take a while. No measures are taken into account in the calculation, so if you
have added many measures, you may be unable to import the selection even if the estimated
number of rows and columns is small. The estimated import size may be of help if an import should
fail. Then, the next time you try to import data from that cube, you should try to make sure that the
estimated size is smaller than the previous time.

When you are done with the data selection, click OK.
The connection is added to the Data tables list in the Add Data Tables dialog.

Make sure the data table, and not the connection, is selected in the Data tables list and, under Load
method, click Import data.

Click OK in the Add Data Tables dialog.
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Result

If the data selection was small enough, the data is imported.

Do all of the data selection work in a shared data connection and save it to the library instead of adding
it to the analysis directly. This way you can reuse the work you have done later, or share your selections
with others.

e During import, sets are applied once. This means that selection of multiple sets with no intersecting
& data will result in a data table without any data.

o PKiIs are not supported.

Settings for Microsoft SQL Server Analysis Services Connection

Use this dialog to connect to Microsoft SQL Server Analysis Services.

P "

Microsoft SOL Server Analysis Services Connection @
Server:
my-analysis-services-server -

Database:
[I'u'l'_.rDatabase v]
Cube:
| MyCube -
Help | oK || Cancel |
Option Description
Server The name of the server where your data is located. To include a port number, add it
directly after the name preceded by colon. To include an instance name, add it
directly after the server name preceded by backslash.
Example with port number: myDatabaseServer:1234
Example with instance name: MyDatabaseServer\ InstanceName
Connect Connects you to the specified server and populates the lists of available databases
and cubes. Microsoft SQL Server Analysis Services only supports Windows
authentication.
Database Select the database of interest from the drop-down list.
Cube Select the cube of interest from the drop-down list.

Working with Cubes in TIBCO Spotfire®
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Oracle Essbase

If you have access to data in an Oracle Essbase system, you can use the Oracle Essbase connector in
Spotfire to connect to your OLAP cube.

When you configure a connection to an Oracle Essbase cube, you can choose whether to analyze data
in-database or to import it into your analysis. Note that you need to install a driver on your computer to
get access to the Oracle Essbase connector. See the system requirements at http://support.spotfire.com/
sr_spotfire_dataconnectors.asp to find the correct driver.

Measures in Oracle Essbase

In an Oracle Essbase cube, you organize measures in one dimension, which you tag as the accounts
dimension. If no dimension in the cube is tagged as accounts, you must specify the dimension where
the measures in the cube are located, when you create a connection in Spotfire.

You define the dimension to use for measures in the Select Measure Dimension dialog, which is
displayed automatically when you connect to an Oracle Essbase cube that does not have an accounts
dimension.

Hierarchical Measures

In Oracle Essbase, measures can be organized in hierarchies, in contrast to other cube data sources.

When the data source structure is shown in Spotfire, a measure that is also a parent is shown both as a
folder and as a separate measure, which is slightly different compared to what the structure looks like
in the Oracle Essbase Administration Services user interface.

Example of Structure

Spotfire

Data Selection in Connection
Oracle Essbase System
The cube structure is shown below. Make selections
limit what is shown.

EMOutine: Basic (Active Alias Table: Default Type to search
- ear Time <> (Aliss: Period) Demo_Basi\c
=-Accounts Accounts <3= (Mo Cormersion :
" &-Proft (+) <2» : ' - s Accounts
o Wargin (+) <2=
Sales [+
Cost (=)
= Expenses (-) «3= B
Iefarketing (+1
Paygroll (+) :
Miscelaneous (+) (Alias: Misc) = -
Profit_% (~) (Two Pass) [Formula  Proft % Seles : - Margin — < lf—

Margin_% (~) (Two Pass) [Formuda:  Margin % Salel

Margin_%

Scenario

In the Data Selection in Connection dialog in Spotfire, only metadata is shown. This means that even if
the Show both member and alias check box has been selected in the Oracle Essbase connection dialog,
the member names will still be shown in the Data Selection in Connection dialog. The aliases will be
shown in the data when the selection has been added to Spotfire.

Working with Cubes in TIBCO Spotfire®
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Adding In-database Data from Oracle Essbase
You can add a data connection to Oracle Essbase to an analysis and select to analyze the data in-

database.

Procedure

1. Select File > Add Data Tables.
The Add Data Tables dialog opens.

2. Click Add > Connection To > Oracle Essbase.
The Oracle Essbase Connection dialog opens.

3. Specify the Server you want to connect to.
4. Enter your credentials in the Username and Password text fields.

5. Click Connect.
Spotfire will connect to the specified server, and retrieve the names of the available applications.

6. From the Application drop-down list, select the application of interest.
7. Specify which database in the selected application you want to work with.

8. In the Alias table drop-down list, select from which table the member names should be retrieved.

An alias table maps the original member name to a more user friendly name, or they could contain
long or short versions of a name.

9. Optionally, select the check box Show both the member name and the alias.
The member name and alias name will be shown in the user interface, separated by comma.

10. Click OK.
The Data Selection in Connection dialog opens.

11. In the left pane, click on the object of interest, and then click Add >.

See Icon Descriptions for information about what the different objects represent. If you select the
cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add
the entire hierarchy to the list, but you can limit the data further, see step 12.

The selected data is added to the Data selection in connection list.

12. Dimension columns and hierarchies can be further limited by clicking on the selected column or
hierarchy in the Data selection in connection list and then, in the Settings pane, clicking Limit....
The Limit Data dialog opens.

13. Clear the check boxes for categories that you want to remove from the selection.
14. Click OK to close the Limit Data dialog.

15. When you are done with the data selection, click OK.
The connection is added to the Data tables list in the Add Data Tables dialog.

16. Make sure the data table, and not the connection, is selected in the Data tables list and, under Load
method, click Keep data external.

17. Click OK in the Add Data Tables dialog.

Result
The external data table is shown in the Data panel.

Do all of the data selection work in a shared data connection and save it to the library instead of adding
K 2 it to the analysis directly. This way you can reuse the work you have done later, or share your selections
with others.
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Importing Data from Oracle Essbase

When you want to import data from an Oracle Essbase cube, it important to limit the selected data as
much as possible.

Procedure

10.

11.

12.

13.
14.
15.

16.

17.

18.

Select File > Add Data Tables.
The Add Data Tables dialog opens.

Click Add > Connection To > Oracle Essbase.
The Oracle Essbase Connection dialog opens.

Specify the Server you want to connect to.
Enter your credentials in the Username and Password text fields.

Click Connect.
Spotfire will connect to the specified server, and retrieve the names of the available applications.

From the Application drop-down list, select the application of interest.
Specify which database in the selected application you want to work with.

In the Alias table drop-down list, select from which table the member names should be retrieved.
An alias table maps the original member name to a more user friendly name, or they could contain
long or short versions of a name.

Optionally select the check box Show both the member name and the alias.

The member name and alias name will be shown in the Ul separated by comma.

Click OK.

The Data Selection in Connection dialog opens.

In the left pane, click on the object of interest, and then click Add >.

See Icon Descriptions for information about what the different objects represent. If you select the
cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add
the entire hierarchy to the list, but you can limit data further, see step 12.

The selected data is added to the Data selection in connection list.
Dimension columns and hierarchies can be further limited by clicking on the selected column or

hierarchy in the Data selection in connection list and then, in the Settings pane, clicking Limit....
The Limit Data dialog opens.

Clear the check boxes for categories that you want to remove from the selection.

Click OK to close the Limit Data dialog.

When you are done with your data selection it is recommended to click the Estimate Import Size
button to get a hint on whether this selection will be possible to import or not.

The calculation may take a while. No measures are taken into account in the calculation, so if you
have added many measures, you may be unable to import the selection even if the estimated
number of rows and columns is small. The estimated import size may be of help if an import should
fail. Then, the next time you try to import data from that cube, you should try to make sure that the
estimated size is smaller than the previous time.

When you are done with the data selection, click OK.
The connection is added to the Data tables list in the Add Data Tables dialog.

Make sure the data table, and not the connection, is selected in the Data tables list and, under Load
method, click Import data.

Click OK in the Add Data Tables dialog.
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Result

If the data selection was small enough, the data is imported.

Do all of the data selection work in a shared data connection and save it to the library instead of adding
R 2 it to the analysis directly. This way you can reuse the work you have done later, or share your selections
with others.

Spotfire for Oracle Smart View Users

If you are an Oracle Smart View user who is accustomed to do ad-hoc analysis, that is, if you are using
Microsoft Excel spreadsheets with Smart View functionality for selecting members from a cube, there
are a number of things you should think about when doing analysis in TIBCO Spotfire.

When doing ad-hoc analysis in Excel, you often start off with all dimensions as columns, and a single
measure on the row. No data is shown until you explicitly refresh the spreadsheet. If you are familiar
with your working cube, you might also be used to the free-form mode, where you type member names
directly into the cells and thereby slice your cube. In Spotfire, there is no free-form mode editing.
Because Spotfire is interactive, you do not have to refresh your spreadsheet explicitly — the spreadsheet
is automatically updated as you go.

The equivalent to the Excel spreadsheet in Spotfire is the cross table visualization. When you create a
cross table visualization, Spotfire will suggest a measure as well as a dimension/hierarchy in the initial
cross table. You should also see the Data panel, which shows you the available dimensions/hierarchies
and measures (if the Data panel is not shown, click the Data button in the toolbar).

Cross table visualization in Spotfire.

Sales per Product and Year

Year (Ar) = + =

Category Type 2011 2012 2013

Y Eruit Apples 50.00 153.00 162.00
+ Bananas 332.00 335.00 34400
O Pears 267.00 266.00 279.00
@_ Vegetables Cucumber 140.00 141.00 22.00
E‘_ Lettuce 245.00 245.00 258.00
E Tomatoes 56.00 161.00 168.00

3

(o

SumiSales) = + -

Because there is no free-form mode editing in Spotfire, you should not start off by dragging all
hierarchies to the visualization and go from there. Instead, you select what measures or accounts to
show in the cells by selecting the appropriate measure in the lower horizontal axis selector in the cross
table (or by dragging the appropriate measure from the Data panel to the axis selector). Also, in
Spotfire, there is no explicit pivot operation. Instead, you select what dimension members to show on
the vertical axis by selecting or dragging the dimension to the vertical axis selector. Similarly, you select
which dimension members should be shown on the horizontal axis by selecting or dragging the
dimension to the upper horizontal axis selector.

Note that you can have multiple dimensions on each axis. Those dimensions then become nested. Also
note that multiple measures can be selected on the lower horizontal axis (value axis), but in that case
"pivoting" is not possible.

In Spotfire, you slice your cube through filtering. That is, in the Data panel, you click on the filter icon
next to the dimension you want to slice. This brings up an appropriate filter in which you select the
member for that dimension. Repeat this for each dimension that should be sliced.

Working with Cubes in TIBCO Spotfire®



~@

31

3 Year
o
sales Type to search in list
+ Ml Expenses ] ()
¥ Profit + [ a1
+ == Market H ] a2
o -l (m] o3
+ coo Product
o [«] Jul
+| oon Geography M Aug
= ;E; Year H [] sep
Quarter + [ ] 04
Maonth

The best way to slice a hierarchy (to select a single member in a hierarchy filter) is to do the following;:

1. Locate the member to slice by in the hierarchy filter by expanding the appropriate part of the
hierarchy (click on the plus-signs before the parents to expand).

2. Right-click on the member to slice by and select Deselect Other Values from the pop-up menu.

If you want to continuously see how the filters are defined, you can click on the Filter button on the
toolbar. This brings up the Filters panel, in which all filters are displayed. You can modify the filter
from within this panel, as well as from the Data panel. In the Data panel, you click on the filter icon
next to the dimension you want to see or modify the filtering for to display the filter.

Often, the visualization will not show any data until all members to slice by have been specified
(filtered) correctly. It is also common that query performance is bad until the cube has been sliced.
Therefore, it might be better to define all the slicers before configuring the visualization correctly (by
selecting the correct measures and dimensions on the axes).

Minimizing the Strain on the Oracle Essbase Database

This topic provides some tips on how to put minimum strain on your Essbase database. You can mimic
the workflow from Smart View use in Excel by first removing all visualizations, then filtering (slicing)
the data, and finally, configuring your visualization.

Mimic the workflow where you configure your visualization or spreadsheet and then refresh to see
results, using these steps:

Procedure

1. Remove all visualizations in the Spotfire analysis.

2. Define the slicers that are needed by filtering the appropriate dimensions in the Data panel.
When you define your slicer member in a hierarchy filter you:
a) Locate and select the slicer member in the filter for the hierarchy.
b) Right-click on the slicer member and select Deselect Other Values from the pop-up menu.

3. Create the visualization (spreadsheet) by clicking the Cross Table button in the toolbar.

4. Specify your measures and dimensions on the various axes in the cross table (spreadsheet).
Result

The cube data is ready to be analyzed.
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If you always want to view a cross table when you create a new Spotfire analysis, you can make the

cross table your default visualization (the visualization that is shown when you bring in new data). To

R 4 do that, select Tools > Options, go to the Document page, and set Initial visualization when loading
data to Cross Table. If you want the filter panel to be automatically displayed, you can select the Filters
panel open by default check box in the same dialog.

Settings for Oracle Essbase Connection

Use this dialog to connect to Oracle Essbase.

Oracle Essbase Connection ot

General Advanced

Server:

|rrr'_.rdatabase.rrr5,rc:nmpan1.r.c:nm:1423 o |

|semame:
| Myl lsemame |

Password:

Connect

Application:

My Application e
Database:

MyDatabase w

Alias table:
Default e

[] Show both member name and alias

e Corcs

Option Description

Server The name of the server where your data is located. Add the port number directly
after the name preceded by colon.

Example: myDatabaseServer:1234

Username The username you wish to use when logging into the Oracle Essbase database.
Password The password for the specified username.
Connect Connects you to the specified server and populates the lists of available

applications and databases.
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Option Description

Application Select the application of interest from the drop-down list.
Database Select the database of interest from the drop-down list.
Alias table Allows you to select which alias table to get the names from.

An alias table maps the original member name to a more user friendly name, or
they could contain long or short versions of a name.

Select 'Do not use aliases' to get the original member names.

Show both Select this check box to show both the member name and an alias name in the Ul,
member name  separated by comma. For example, you could show both a product ID and the
and alias product name like this: PNO2345, Fruit drink

Select Measure Dimension

&

If you are connecting to an Oracle Essbase cube that does not have a dimension tagged as the accounts
dimension, you must specify which dimension contains the measures. When you create a connection to
such a cube, this dialog will be displayed, and you can manually specify which dimension to use as the
designated measure (accounts) dimension in your connection.

Working with measures in a Spotfire-designated accounts dimension

When you work with data from an Oracle Essbase cube which has no accounts dimension, Spotfire can
only use the aggregation function SUM to make any further calculations of the measures in the
Spotfire-designated accounts dimension. When you work with a regular Oracle Essbase cube, which
already has a default accounts dimension, Spotfire uses the function AGGREGATE when it needs to
calculate measures, which means that the underlying operations in the measures are used for
aggregation.

In Spotfire, calculations of measures are performed, for example, in certain cases of filtering.

When you work with an Oracle Essbase cube which has no accounts dimension, keep the following

in mind:

o Avoid using measures that are aggregated with functions other than SUM, or you might get
unpredictable results in your Spotfire analysis.

 If the measures use other aggregations than SUM, contact your database administrator. You will
have more options when creating your Spotfire analysis, if your database administrator tags the
dimension with the measures as the accounts dimension in the cube. Otherwise, be aware that
calculations of measures from a Spotfire-designated accounts dimension will use the function SUM.

Settings for Select Measure Dimension
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Select Measure Dimension ot
There is no accounts dimension defined in this cube. Select a
dimension that contains the measures, to use it as the accounts
dimension in the connection.
Available dimensions:
Tvpe fo search
Messires |
Years
Time
Transaction Type
Payment Type
Promotions
Age
Income Level
Products
Stores
Geography
Store Manager
Square Footage
Area Code
Help [ ok | Cancel |
Option Description
Auvailable Lists all the dimensions in the cube.
dimensions To select which dimension to use as the measure (accounts) dimension, click the
dimension that contains measures. Then click OK.
[Type to Type a search string to limit the number of dimensions listed in the Available
search] dimensions list.
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SAP BW

If you have access to data in an SAP BW system, you can use the SAP BW connector in Spotfire to
connect to your OLAP cube.

Note that you need to install a driver on your computer to get access to the SAP BW connector. For
more information and instructions for installing the required drivers, see Installing Drivers for the SAP
BW Connector.

Installing Drivers for the SAP BW Connector

The Spotfire connector for SAP BW can employ either the BAPI interface, or the ODBO interface, for
connecting to SAP BW systems. This depends on which data source driver you have installed on your
computer.

Supported data source drivers

The Spotfire connector for SAP BW supports the following data source drivers:

e SAP NetWeaver RFC SDK (BAPI driver)
e SAP BW OLE DB for OLAP provider (ODBO driver)

& If you have both the BAPI driver and the ODBO driver for the SAP BW connector installed on your
computer, the connector will use the BAPI driver.

Which driver should | use?

It is recommended to use the BAPI driver (SAP NetWeaver RFC SDK).

With the BAPI driver installed, if you enable the preference setting
UseNativeSapFunctions AllowingMoreThanOneMillionCells, in the Spotfire Administration manager, you
can load data that exceeds 1M cells from SAP BW.

Installing the BAPI driver (SAP NetWeaver RFC SDK) for the SAP BW connector

Prerequisites

Download the appropriate installation files for your system from the Download Software area of the
SAP Support Portal. You need the following:

e SAP NW RFC SDK .sar file

o SAPCAR utility .exe file

Procedure

1. Create a new directory where you want to install SAP NetWeaver RFC SDK.
2. Place both the NWREFC .sar file and the SAPCAR utility .exe file in the directory you just created.

3. Open a command-line interface (for example Command Prompt in Windows) and change the
working directory to the directory where you placed the installation files.

Example command:
cd C:\SAP NetWeaver RFC SDK

4. Run the following command: <SAPCAR utility file name> -xvf <NW RFC SDK file name>

Example command:
SAPCAR_712-80000938.exe -xvf NWRFC_42-20004568.sar

This will unpack the .sar archive and place its contents in the same directory.
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5. In the directory where you opened the .sar file, you should see a new directory called ‘nwrfcsdk’.
This is your installation of SAP NetWeaver RFC SDK.

6. Inthe ‘nwrfcsdk’ directory, locate the directory that contains (among other files) the sapnwrfc.dll
file. The directory is usually named ‘lib’. Note down the full path to this directory.

Creating the required environment variable
7. To create the required environment variable, open System Properties, and, on the Advanced tab,

click Environment Variables....

8. In the Environment Variables dialog, create a new system variable or user variable.

& ‘ For Web Player or Automation Services services, you must use a system variable.

9. In the New System Variable dialog, enter the following Variable name: DXP_NWRFCSDKLIB
10. For the Variable value, enter the full path to the directory in your SAP NetWeaver RFC SDK
installation where the sapnwrfc.dll file is located.
For example:C:\SAP NetWeaver RFC SDK\nwrfcsdk\lib

Which driver is my SAP BW connector running?
If you have both the BAPI driver and the ODBO driver for the SAP BW connector installed on your
computer, the connector will use the BAPI driver.
If you are not sure what drivers you have installed on your computer, you can easily find out which
driver the SAP BW connector is using.

Procedure

1. In Spotfire, click Add Data Tables....
2. Inthe Add data tables dialog, select Add > Connection to > SAP BW.

3. In the title of the SAP BW Connection dialog, information about the driver that the connector is
running is appended inside parentheses (BAPI or ODBO).

InfoProviders

InfoProviders are the reportable entities in SAP BW, for example, InfoCubes and MultiProviders.

InfoCubes

InfoCubes are multidimensional models in SAP BW. In Spotfire, the InfoCubes become cubes (that is,
data tables). Standard InfoCubes are self-contained data sets for particular business subjects or
processes, such as sales, lost deals, and plans. They consist of dimensions, characteristics, key figures
and navigational attributes.

MultiProviders

Because each InfoCube normally only supports an individual business subject or process, there is a
need to create reports where data from different processes are joined. MultiProviders are used for this
purpose. They exist as a logical definition only, so they do not physically store any data.
MultiProviders are also frequently used in cases where a single InfoCube would become very large
due to high data volume. MultiProviders also become cubes (that is, data tables) in Spotfire.
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Business Explorer (BEx) Queries

SAP BW users can create Business Explorer (BEx) queries in the BEx Query Designer. BEx queries are
intended to provide the end users with queries for reporting and analysis in SAP BW. In Spotfire each
BEx query becomes a cube.

For a BEx query to be visible in Spotfire, the query has to be configured to allow external access by OLE
DB for OLAP. This is done by selecting the Allow External Access to this Query by OLE BD for OLAP
check box in the Extended tab in the Query Properties for the query in the BEx Query Designer
application.

When you select an SAP BW BEx query in Spotfire, you may have to specify desired values for
predefined variables. The specified values will be used to limit the selected data. Once the BEx variables
have been specified, you cannot change them.

Variables

&

Variables act as parameters to a Business Explorer (BEx) query. They are filled with values and
processed at query runtime.

For example, you might have a BEx query that reports sales for the year 2014. When new data for 2015
becomes available, you do not want to change the year to 2015, but rather want the end user of the
query to select which year the query should be executed for.

In that case, you modify (parameterize) the query so that it uses a variable for the year. Then, the end
user can specify the year of interest by selecting a value for that variable when the Spotfire analysis is
opened.

When working with BEx queries with variables, avoid limiting characteristics using the Limit Data
dialog. Data has already been limited by the selections in the BEx variables, so, generally, further
limiting is not necessary. Because of restrictions in SAP BW, if you both limit a characteristic and define
a BEx variable that filters out values for that characteristic, you might get unpredictable results when
loading and analyzing data.

Variables are globally available, so that once they are defined, they are available for use in any BEx
query. However, not all variables are available to Spotfire. The underlying SAP BW driver does not
return any Text variables. In addition, only variables that have the processing types Manual Entry or
Default Value are returned by the driver.

‘ Hierarchy variables are not supported by Spotfire. Hiearchy node variables, however, are supported.

Key Figures

Key figures are numeric values, quantities, dates or times.

For example, typical key figures are sales revenue, or, quantity sold. That is, key figures are the
measures of the cube and the are found under 'Key Figures' in the Spotfire Data panel.

SAP Message Server

An SAP message server can be used for load distribution and communication between individual
application servers in an SAP BW system. When you create an SAP BW connection in Spotfire, you
must specify whether you will connect directly to an application server, or if you want to connect via a
message server.

To connect to an SAP BW data source via a message server, select Connection type > Group/Server
selection in the SAP BW connection dialog. Different information is required to create a connection to
an SAP BW data source via a message server, compared to when you connect directly to the application
server.
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Characteristics

A characteristic usually denotes a business entity that is being evaluated or measured by a key figure.
Characteristics can be either attributes or hierarchies. Attributes are further broken down into display
attributes and navigation attributes.

SAP BW hierarchies are represented as hierarchies in Spotfire. Navigation attributes are represented as
columns in Spotfire. Display attributes are currently not available in Spotfire.

Navigation attributes can be used in BEx queries for drilling and filtering and are thus visible to
Spotfire (in the context of the BEx query).

Navigation attributes appear as display attributes in the context of an InfoCube and are therefore not
& visible in Spotfire in that context. If you need to access these attributes in Spotfire, the workaround is to
create a BEx query based on the InfoCube, and expose the navigation attributes in the BEx query.

Dimensions
In SAP BW, dimensions are groupings of logically related characteristics.

However, not all characteristics belong to a dimension, so Spotfire does not show these dimensions.
Instead, all characteristics are found under the 'Characteristics' dimension in Spotfire.

Adding In-database Data from SAP BW

Follow the steps below to add a connection with in-database data to SAP BW.

Procedure

1. Select File > Add Data Tables.
In the Add Data Tables dialog, click Add > Connection To > SAP BW.

3. Inthe SAP BW Connection dialog, enter the information and credentials for the data source you
want to connect to.

4. Click Connect.
Spottire will connect to the specified server, and retrieve the names of the available catalogs, cubes,
and BEx queries.

5. In the Catalog drop-down list, you can narrow down the amount of listed cubes. Cubes containing
BEx queries are listed, but you can also select (All cubes) if you do not want to narrow down the
selection.

6. Inthe Cube or query drop-down list, select the cube or query of interest.

If a name is preceded by a dollar sign ($) in the drop-down list, it is a cube, otherwise it is a BEx
query.

7. Click OK.

The Data Selection in Connection dialog opens.

If you selected a BEx query with variables, the BEx variables will automatically be added to the
Data selection in connection list. Variables listed as Mandatory must be defined if no default has
been specified already. Variables listed as Mandatory not initial must always be defined. Click on
each variable to display its settings and click Define Value to specify values for each variable.

8. Click on the object of interest in the left pane, then click Add >.

See Icon Descriptions for information about what the different objects represent. If you select the
cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add
the entire hierarchy to the list, but you can limit data further, see step 12.

The selected data is added to the Data selection in connection list.
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9. Dimension columns and hierarchies can be further limited by clicking on the selected column or
hierarchy in the Data selection in connection list and then, in the Settings pane, clicking Limit....
The Limit Data dialog opens.

10. Clear the check boxes for categories that you want to remove from the selection.
11. Click OK to close the Limit Data dialog.

12. When you are done with the data selection, click OK.
The connection is added to the Data tables list in the Add Data Tables dialog.

13. Make sure the data table, and not the connection, is selected in the Data tables list and, under Load
method, click Keep data external.

14. Click OK in the Add Data Tables dialog.
Result
The external data table is shown in the Data panel.

Do all of the data selection work in a shared data connection and save it to the library instead of adding
it to the analysis directly. This way you can reuse the work you have done later, or share your selections
with others.

~@

Importing Data from SAP BW
Follow the steps below to import data from a SAP BW cube.

Procedure

1. Select File > Add Data Tables.
2. Inthe Add Data Tables dialog, click Add > Connection To > SAP BW.

3. Inthe SAP BW Connection dialog, enter the information and credentials for the data source you
want to connect to.

4. Click Connect.
Spottfire will connect to the specified server, and retrieve the names of the available catalogs, cubes,
and BEx queries.

5. In the Catalog drop-down list, you can narrow down the amount of listed cubes. Cubes containing
BEx queries are listed, but you can also select (All cubes) if you do not want to narrow down the
selection.

6. Inthe Cube or query drop-down list, select the cube or query of interest.

If a name is preceded by a dollar sign ($) in the drop-down list, it is a cube, otherwise it is a BEx
query.

7. Click OK.

The Data Selection in Connection dialog opens.

If you selected a BEx query with variables, the BEx variables will automatically be added to the
Data selection in connection list. Variables listed as Mandatory must be defined if no default has
been specified already. Variables listed as Mandatory not initial must always be defined. Click on
each variable to display its settings and click Define Value to specify values for each variable.

8. Click on the object of interest in the left pane, then click Add >.

See Icon Descriptions for information about what the different objects represent. If you select the
cube icon, you will get all data in the cube. When it comes to hierarchies, you always have to add
the entire hierarchy to the list, but you can limit data further, see step 12.

The selected data is added to the Data selection in connection list.
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9. Dimension columns and hierarchies can be further limited by clicking on the selected column or
hierarchy in the Data selection in connection list and then, in the Settings pane, clicking Limit....
The Limit Data dialog opens.

10. Clear the check boxes for categories that you want to remove from the selection.
11. Click OK to close the Limit Data dialog.

12. When you are done with your data selection it is recommended to click the Estimate Import Size
button to get a hint on whether this selection will be possible to import or not.

The calculation may take a while. No measures are taken into account in the calculation, so if you
have added many measures, you may be unable to import the selection even if the estimated
number of rows and columns is small. The estimated import size may be of help if an import should
fail. Then, the next time you try to import data from that cube, you should try to make sure that the
estimated size is smaller than the previous time.

13. When you are done with the data selection, click OK.
The connection is added to the Data tables list in the Add Data Tables dialog.

14. Make sure the data table, and not the connection, is selected in the Data tables list and, under Load
method, click Import data.

15. Click OK in the Add Data Tables dialog.
Result
If the data selection was small enough, the data is imported.

Do all of the data selection work in a shared data connection and save it to the library instead of adding
L 2 it to the analysis directly. This way you can reuse the work you have done later, or share your selections
with others.

&

Prompting for SAP BW BEX Variables

You can define prompting for a data connection to an SAP BW BEx query. Using prompting, you can let
the end user define values for BEx variables, upon opening the connection.

» Itis not possible to import multiple characteristics that belong to the same dimension.

In BEx queries, variables are used to limit the data to be loaded. Prompting can bring greater flexibility
to a BEx query connection, as you can use it in place of static values for BEx variables. By defining BEx
variables via prompts, one connection can be used to load different data from the source depending on
the user input.

Some variables are 'Mandatory' and values must be defined before the query can be opened. By setting
up prompting, you can let the end user define the variable value, instead of defining it in the connection
configuration.

You can define both a value and prompting for the same BEx variable. The variable value you define in
the connection will be the default selection in the prompt dialog for the variable when opening the
connection, which can be useful if you save the connection in the library for reuse. However, if you

& create an analysis where prompts will be shown to the end user, then your selection in the prompts
when opening the connection will be stored in the analysis. Your selection in the prompts, rather than
the variable values you defined in the connection, will then be the default selection in the prompts to
the end user.

Compared to working with relational data sources, BEx queries are more restrictive regarding how you
can set up prompting. When a variable is defined in the query, it is designed to only accept certain
input; for example single value, multiple value or range. In Spotfire, the accepted input determines
what prompt types you can use for a BEx variable.
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By default, unless Load values automatically is selected, prompts for BEx variables will give users the
option to manually enter values. When typing variable values manually, Spotfire supports entering
values as text (captions). Entering values as keys is not supported.

Adding Prompts to an SAP BW BEx Query Connection

You can define prompting for a data connection to an SAP BW BEx query. Using prompting, you can let
the end user define values for BEx variables, upon opening the connection.

Prompting can bring greater flexibility to a BEx query connection, as you can use it in place of static
values for BEx variables. By defining BEx variables via prompts, one connection can be used to load
different data from the source depending on the user input.

Prerequisites

The following example describes the process for adding prompting for a BEx variable in a saved
connection in the library. However, you can add prompts to connections embedded in an analysis file
too.

Procedure

1. Select Tools > Manage Data Connections.

2. Locate the SAP BW BEx query connection of interest and click Edit.
You might need to enter the data source credentials to proceed.

3. In the Data Connection Settings dialog, click Edit....
The Data Selection in Connection dialog is displayed.

4. In the Data selection in connection list, select the BEx variable that you want to define prompting
for.

5. In the Settings pane, select Prompt for values.

In the Prompt type menu, select the desired prompt type.

Comment: What prompt type you can use depends on what input the selected BEx variable is
configured to accept. For example, if the variable accepts only a single value, you will only be able
to select the prompt type 'Single selection'.

7. Select whether or not to Load values automatically in the prompt.

Comment: By default, this option is not selected and the user can choose either to load a list of all
available values to select from, or to type values in the prompt manually. Typing values can be
preferable, especially when the user needs to select a large number of values. The user can then use
a saved list of values, by loading a file with text values or pasting it in the input field. If you select
not to load values automatically, the end user will not have the option to type values manually.

8. Optionally, type a Description to be shown in the prompt dialog, explaining what type of value that
the end user should provide.

9. (lick OK, and then, in the Data Connection Settings dialog, click Save.

To show prompts when opening an analysis with an embedded connection with prompting

&

If you have saved an analysis with an embedded connection with prompting, by default, the end user
will not be prompted for input upon opening the analysis. The data selection will be based on the
selection that you made in the prompts, when authoring the analysis. Follow these steps to show the
prompts and let the end user define variable values, upon opening the analysis.

Your selection in the prompts, when authoring the analysis, will be the default selection in the prompts
to the end user.
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1. Select Edit > Data Table Properties.

2. In the Data Table Properties dialog, on the General tab, click Linked (individual settings per

source).

Select Prompt for new settings before loading.

4. Click OK.

Details on Prompting for SAP BW BEXx Queries

Prompting for BEx queries is defined in the Data Selection in Connection dialog. Click a BEx variable
and, in the Settings pane, the following options will be available to define prompting.

Data Selection in Connection

search to limit what is shown.

The cube structure is shown below. Make selections or Data selection in connection:

Type to search

sex Varables

G
= 2 Key Figures
i & Costs
% Discourt

5 Sales
= I, Charactenistics
(- 17 Category
- 1. Region
]4 State

Help

*
=T Settings:
Type to search C
sex Varables (1) Mandatory not intial
(1) Discount (Default) Value presentation:
@ Categories T[Prompted} Text "
Add = ) ) States (Defined) Variable value:
[] SALESDATA
< Bemove 241", Characteristics Define Value. ..
1 Category
- 17 Region
EI— Region
- 17 State
Prompt for values
Prompt type:
Muttiple selection w
Min selections: Max selections:
1 = [15 =
Load values automatically
Description:
Select the categories you want to analyze.
Order of Prompts...
Estimate Import Size
Canc

Settings

Option Description

Value presentation

Used to specify how the values of a characteristic (dimension) will be

presented in Spotfire. You can choose to display text only, the technical
key or a combination of both.

If you have selected a BEx variable, your selection in this menu specifies
how the variable values will be presented in the Define Value dialog and
prompts for the variable.
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Option Description

Variable value Click to open the Define Value dialog, where you can define a value for
the selected BEx variable.

Prompt for values Select this option to prompt the end user for input to define the selected
BEx variable.

Prompt type Specify the input type to use when prompting the end user.

Depending on the BEx variable, different prompt types will be available.
This is the full list of prompt types:

Range
Multiple selection
Single selection

Hierarchy selection

Load values [Only available for 'member' BEx variables.]

automatically Select to load available values when prompting the end user to define a

variable value. The end user will be able to select from a list of all
available values.

By default, this option is not selected and the user can either type values
in the prompt manually or load the list of values to select from.

Typing values manually can be a preferable input method,
especially when the user needs to select a large number of

& values. Using manual input, the user can paste a list or load a
saved file with variable values, instead of selecting them one by
one.

Min / Max selections [Only available for the prompt type 'Multiple selection'.]

Used to specify the minimum and maximum number of selections that
can be made in the prompt.

Description Type a description that will be shown in the prompt.

This is a good opportunity to explain to the end user what input is
expected for the BEx variable. This is especially important when available
values are not loaded and shown to the user.

Order of prompts Opens the Order of Prompts dialog, where you can specify in what order
the prompts will appear to the end user of the connection.

The prompt order is important, because the selection in one
prompt will reduce the available values before the next prompt
8 is shown. Properly ordered, the prompts are more intuitive to
understand for the end user. You also reduce the risk of
allowing user input that will reduce the data so much that
other prompts become empty.
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Best Practices for the SAP BW Connector

When you work with SAP BW data in Spotfire, there are certain restrictions in SAP BW that you should
keep in mind. The following sections contain information describing common SAP BW limitations and
suggestions for how you can work around them.

Default Cell Limit: Maximum 1 000 000 Cells

By default, there is a limit to how many cells of data can be returned in a single query from Spotfire to
SAP BW. The MDX interface of SAP BW can generate a result set containing a maximum of 1M cells.
There is a preference setting, that a Spotfire administrator can enable, to make Spotfire use a special set
of functions to query SAP BW data sources. Enabling the preference
UseNativeSapFunctionsAllowingMoreThanOneMillionCells will allow you to work with larger
amounts of data from SAP BW. For more information, see SAP Note 1232751.

& For this preference setting to have any effect, you must have installed the BAPI driver (SAP NetWeaver
RFC SDK) on your computer.

Working within the default SAP BW cell limit

If you are running the SAP BW connector with the ODBO driver (SAP BW OLE DB for OLAP
provider), or if you have not enabled the preference setting for working with SAP BW data that exceeds
1M cells, consider the following recommendations for working within the restrictions of the SAP BW
1M cell limit.

To avoid exceeding the SAP BW cell limit for in-database data:

o Use filters to limit the data in your analysis.

e Include a key figure (measure) when you set up a visualization.

& If a query to an SAP BW data source includes no key figure (measure), more data than
intended might be returned from the data source.

To avoid exceeding the cell limit when you import SAP BW data:

e In the Data Selection in Connection dialog, reduce your data selection as much as possible. Only
include columns and hierarchies that are relevant to your analysis. Define BEx variables and limit
characteristics to only include data for values of interest.

o Click Estimate Import Size to evaluate whether the selected data can be imported.

e Include a key figure (measure) in the data selection.

& If a query to an SAP BW data source includes no key figure (measure), more data than
intended might be returned from the data source.

Importing SAP BW Data in Pieces

If you want to analyze a very large amount of SAP BW data, which exceeds the limit of 1M cells, you
can import it piece by piece into Spotfire.

To import data in pieces, limit the data selection to only include data for a portion of the values in a
characteristic or variable. Then, in your analysis, use Insert Rows to add more pieces of the data to the
data table containing the imported data.

Procedure

1. In the Data Selection in Connection dialog, select the data you want to import from the data source.
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2. Identify a characteristic or variable that contains a suitable number of categorical values to limit the
data to.

Example: If you have a data source with sales data for the year 2016, the characteristic 'Calendar
day' contains too many values for it to be practical to piece the data by. The characteristic 'Quarter’
is more suitable, because it contains only 4 values. By limiting the data by 'Quarter’, you can import
the data in 4 pieces, each containing only the data for the specified quarter of the year.

3. Click the characteristic or BEx variable and limit the data to only one value.

Tip: You can limit the data to more than one value. For example, you could make an import of the
data for 'Q1-Q2' first, and then add the rows for '‘Q3-Q4' in a second import.

Click OK to close the Data Selection in Connection dialog.

In the Add Data Tables dialog, click Import data. Then click OK.

Select Insert > Rows.

In the Insert Rows dialog, select the data table containing the data from your SAP BW data source.
Click Select > Connection To > SAP BW. Connect to your SAP BW data source again.

© % N o 9o

In the Data Selection in Connection dialog, select the same data you selected in step 1.

10. Click the characteristic or BEx variable that you used to limit the data import in step 3, and make a
new selection to limit the data.

11. Click OK and, in the Insert Rows dialog, click Finish.
12. Repeat steps 6-11 until you have imported all the data you want to analyze.

Limitation: Multiple Hierarchies or Columns from the Same Characteristic
SAP BW does not support mixing hierarchies or columns that are based on the same characteristic. If
more than one hierarchy or column is based on the same characteristic in your data source, make sure
you only include one of those columns or hierarchies.

Procedure

1. In the Data Selection in Connection dialog, select the data you want to analyze.

2. In the Data selection in connection list, expand each characteristic to inspect associated hierarchies
and columns.

3. If any characteristic contains more than one hierarchy or column, make sure you only include one,
by selecting the redundant hierarchies or columns and then clicking <Remove.

Other Tips for Using the SAP BW Connector

The following tips are useful suggestions to keep in mind when you use the Spotfire connector for SAP
BW.
Navigational attributes

To use navigational attributes in Spotfire, the attributes must be exposed in a BEx query.

Do not limit BEx variable characteristics

If you are connecting to an SAP BW BEx query with variables, avoid limiting characteristics in the
Limit Data dialog. If you both limit a characteristic and define a BEx variable that filters out values for
that characteristic, you might get unpredictable results when loading and analyzing data.
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Settings for SAP BW Connection
Use this dialog to connect to SAP BW.

& The SAP BW connector supports both a BAPI and and an ODBO driver. In the title of this dialog,
appended inside parentheses, you can see information about which type of driver (either BAPI or
ODBO) that the SAP BW connector is using.
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SAP BW Connection (BAPI) ot

General  Advanced

Connection type:
|Pq:up|icatiur1 SEMVEr w |

Application server:
|rrr§,fsapbw.rrr§,fcumparr:.f.cnm o |

Group/Server:

Client: System number:
[800 NE |

Language:
[EN |

Authentication method:
| SAP BW authentication v|

SNC partner name {optional):

|semame:
| My Usemame |

Password:

Catalog:
(Al cubes) v

Cube or queny:
| Sales Data v

Help [ ok | cancal |

Option Description

Connection Select the type of SAP BW connection you want to create. Application server
type

Connect directly to an SAP BW application server.
Group/server selection

Connect to the data source using a logon group, via a message server.
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Option Description

Application [Only available for connection type 'Application server'.]
server The name of the server where your data is located.

The server can be identified in the following ways:

o By IP address. For example: 192.0.2.1

o By IP address, but including a SAProuter string. For example: /H/198.51.100.1/S/
3299/H/203.0.113.1/H/CPCB701

e By name in the domain. For example: my-sap-bw.mycompany.com

Message [Only available for connection type 'Group/Server selection'.]

server The name of the message server in the SAP BW system you want to connect to.

Group/Server  [Only available for connection type 'Group/Server selection'.]

The name of the SAP logon group.

Client The SAP BW client number.

System [Only available for connection type 'Application server'.]

number The SAP BW system number.

System ID [Only available for connection type 'Group/Server selection'.]
The SAP BW system ID.

SNC partner ~ The Secure Network Communication (SNC) partner name which is required when
name using single sign-on.

Language Use this field to specify the language used in your data. Refer to official SAP
documentation for a complete list of supported language codes.
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Option Description

Authenticatio =~ The authentication method to use when logging into the database. Choose from
n method Windows authentication and SAP BW authentication.

Windows authentication

When using Windows authentication, the access token of the logged in user will be
used. Users that have been given the appropriate access rights to SAP BW will be
able to connect and read data.

For more information about using single sign-on with the SAP BW connector, see
this page on the TIBCO Community.

Domain credentials are not stored in the analysis file.
SAP BW authentication

Authenticate using a database user.

Users who open the connection, or an analysis using the connection, will be
prompted to enter database credentials to connect to the data source.

You can save database credentials, unencrypted, as part of an analysis
file, using a setting in the Data Source Settings dialog. If credentials are

& embedded in your analysis, it means that users will not be prompted to
enter credentials to connect to the data source. Note that it can be a
security risk to embed database credentials in an analysis file.

Username The username you wish to use when logging into the SAP BW cube or query.
Password The password for the specified username.
Connect Connects you to the specified server and populates the lists of available catalogs

and cubes below.

Catalog Select the catalog of interest from the drop-down list. You can choose among (All
cubes) and cubes containing BEx queries.

Cube or query  Select the cube or BEx query of interest from the drop-down list. If the catalog
selected is (All cubes), only cube names are shown here; if the catalog selected is a
cube, only its BEx queries and the cube itself will be included here. If a name is
preceded by a dollar sign ($) in the drop-down list, it is a cube, otherwise it is a BEx

query.
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SAP BW Connection (BAPI) ot

General Advanced

Operation timeout {minutes):
10

Description
Operation Specifies the maximum time, in minutes, allowed for a command to be executed.
timeout
(minutes)
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Define Value

This dialog is used to specify a value for a BEx query variable. The appearance of the dialog depends on
the type of variable you have selected, but a few examples are shown below:

Define Value
Select values for varable StatesVarable:

@ From list of values

TNype fo search

[C] Arizona -
[¥] California [
[ Colorado

Florida

[ Georgia

 Wlios |
[]Indiana

[ Maszachusetts

[ Michigan

[ Missouri >
Value presentation:

| Text -

m

() Manually (zeparate using comma, semicolon, or new line)

Help | ok || Ccancel |

Option Description

Select a value for
variable [variable
name]

From list of values Select this option to choose variable values from a list of available values

in the data source. Depending on the variable type, it can be a regular or
a hierarchical list.

This will filter the retrieved data so that only data relevant to your
selection will be seen in Spotfire.
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Option Description

Load variable values
from data source

This link is shown to prevent automatic loading of a large number of
values from the data source, which may take a long time.

Click on the link to show all available values from the source.

Value presentation

Select how you want to present the different values in the resulting
column in Spotfire.

Manually (separate
using comma,
semicolon, or new line)

Select this option to manually type or paste values of interest.

Also, select this option if you want to load values from a previously
saved list.

Load from File...

[Only available when variable allows multiple value selection.]
Click to select a file with text values to filter on.

California

Florida

Arizona

Supported file formats are CSV or TXT.

Supported delimiters are line break, comma, tab and semicolon.

Define Value

Select a value for vanable Level:

20

Help

0K || cancel

Select a value for
variable [variable
name]

Description

Type a numeric value of interest for the specified variable. This will filter
the retrieved data so that only data relevant to your selection will be seen
in Spotfire.
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Define Value @

Select a range for varable Orderld
i@ From list of values

Beload varable values

From: Tao:
[2010 ~| 2015 -|

Walue presentation:
[Text )
() Manually

e |

Fili

2007 |

Help | oKk || Cancel |

Option Description

Select a range for

variable [Variable

name]

From list of values Select this option to choose variable values from a list of available values
in the data source.
Select the 'From' and 'To' values of interest in the drop-down lists. This
will filter the retrieved data so that only data relevant to your selection
will be seen in Spotfire.

Load variable values This link is shown to prevent automatic loading of a large number of
values from the data source, which may take a long time.
Click on the link to show all available values from the source in the drop-
down lists.

Value presentation Select how you want to present the different values in the resulting
column in Spotfire.

Manually Select this option to manually type or paste values of interest.
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Data Import

When you add data tables from a data connection, you have the option to either keep the data table
external or to import it into the Spotfire data engine and use it in-memory.

When you are importing cube data into Spotfire you will actually flatten the cube into a single data
table, which means that some features that you have access to when working with an in-database cube
are lost and you may see different results when aggregating your imported data in Spotfire compared
to what you get when the external system does all the aggregation. Spotfire does not import aggregated
data, only leaf nodes that then can be aggregated using the Spotfire aggregation methods.

If you are interested in all of the data from an OLAP (Online Analytical Processing) cube, it is probably
& a better idea to use an in-database connection, while import is mainly intended for small subsections of
the cube data.

Limit the Number of Dimensions

If you intend to import data from a cube into Spotfire there are a number of things that you must
remember.

First of all, the full cube may be enormous, so it is recommended to always limit the dimensions to
import to those that are absolutely necessary only, to reduce data explosion as much as possible. If a
cube like the one shown to the left below is imported into Spotfire, you will get the table shown to the
right. The visualizations you set up will then decide how to aggregate the measures from the resulting

table.
- Sales Country  City State-Province Sales
_ Customer Germany Berlin Heszen S681.11
E = Geography France Bobigny Seine Saint Denis 10813.63
L Courtry —®  Frenee Bobigny Seine Saint Denis 9390 53
______ State-Province France Cergy Wal d'Oise 13173.19
______ City France Chatou fveline 9695.73
France Colombes Hauts de Seine 105889.62
France Colombes Hauts de Seine 9421.91
France Colomiers Garonne (Hautg) 1224270
France Dunkerque Mord 13265.95

When an imported cube data table is aggregated (for example, with the default Sum aggregation), the
available leaf values are simply summarized when you show a categorical value of a higher level (e.g.
the Sum(Sales) for France from the table above). However, in the in-db cube, it is the external system
that decides what an aggregation means, which may include other aggregation methods, data that was
not included in the import, and so on, which may produce a completely different result.

As an example of the importance of limiting the data as much as possible prior to import, imagine a
cube with the following number of values for different dimensions.

Department: 10
Product: 5000
Currency: 20
Business Unit: 1000
Scenario: 10

Account: 100
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Bringing in the entire cube would result in a cross-joined table with the following number of columns:
10x5000x20x1000x10x100=1x10 12

As you can see, the amount of data very quickly explodes with the number of dimensions used,
especially if each dimension contains many different values. Take care not to overload the data source
by combining too many dimensions.

Data Import Best Practices

To get the most out of your data, follow these recommendations for import of data from cubes.

Limit the data to import as much as possible by selecting only the necessary dimensions and
measures in the Data Selection in Connection dialog.

Limit data further by clearing check boxes for undesired categories in the selected data in the Limit
Data dialog.

Click Estimate Import Size to try to evaluate whether import is possible before you try to import a
data selection.

Known Limitations

On-demand is not supported for cube data sources (neither for imported cubes nor for in-database
cubes).

In contrast to data connections from relational data sources, selections for cube data connections
always result in a single data table.

You cannot switch from an imported configuration to an in-database configuration in a cube data
connection, the way you can with relational data sources, or vice versa. However, you can always
replace a data table based on a cube data connection with another data table.

When cube hierarchies have been added to a connection, the hierarchies in Spotfire will not be
updated when the data connection is edited. However, you can always recreate new hierarchies
manually.

Import of large amounts of data may not work. If you try to import and it fails, edit the connection
and limit the selected dimensions and/or categories some more.

The estimation of the expected import size is only an approximation and cannot give any definitive
information regarding whether or not an import will work. If the estimation takes a long time it
often, but not always, means that the result of the selection is too big to import.

If multiple instances of one leaf value exist you may get different behavior between imported data
and in-db data, since the imported data may have lost hierarchical information required in order to
distinguish the leaf values from each other. For example, there is more than one city called Berlin in
the world and after an import, all of those cities will be clumped together into one group in the
flattened data table, unless you make sure to always include full hierarchies on all axes.

You will always get the leaf nodes for those branches in the hierarchies you select. This means that
you can only select full hierarchies, not single columns from a hierarchy.
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Creating a Shared Data Connection in the Library

If you want to be able to use a data connection in multiple analyses or share it with other users, you can
create a data connection item in the library.

Procedure

1. In the Spotfire Windows client, select Tools > Manage Data Connections.

2. In the Manage Data Connections dialog, select Add New > Data Connection and choose the
selected data connection type from the list.
The connection configuration dialog for the selected data source opens.

3. Provide all the necessary input for the connection to the data source and specify which data to
include.

For more information about specific system settings, see the section about the system of interest in
this user's guide.

4. Save the connection to the library.
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